problèmes de balise son dans firefox

Accueil Forums Programmation WIMS Programmation dans le langage wims problèmes de balise son dans firefox

Ce sujet a 3 réponses, 3 participants et a été mis à jour par  Chantal Causse, il y a 3 ans et 3 mois.

  • Auteur
    Messages
  • #2251

    Yves Dhenain
    Participant

    Bonjour, je viens d »installer un serveur wims pour un lycée, nous faisons pas mas de test et il y a visiblement un problème avec la série d’exercice d’anglais, le son ne fonctionne pas sous firefox, les balises sont obsolètes.
    En imaginnt que j’en ai les capacités, qulle méthode faudrait -il suivre pour récrire cet exercice. comment récupérer le code et quelle marche à suivre, j’ai vu qu’il y avait plusieurs méthodes pour écrire des exercices comment savoir comment celui-ci(https://193.50.91.122:2443/wims/wims.cgi?session=LL6A53DA1B.5&+lang=fr&+module=H1%2Fenglish%2Foefpeople.fr&+cmd=new&+worksheet=3&+exo=vocabulairesound&+qnum=1&+qcmlevel=3&+scoredelay=) à été écrit.

    Merci

  • #2254

    bernadette
    Admin bbPress

    Le problème des balises audio est pour moi un cauchemar, car quand cela marche
    sur un navigateur, cela ne marche plus sur un autre.
    Ici, il y a le problème supplémentaire qu’on est dans un exo de correspondance.

    Par contre, on essaie de centraliser les codes audio en question.
    Il ne s’agit donc pas de réécrire l’exercice qui s’appuie sur
    un slib audio (media/audio). C’est lui qu’il faut adapter.

    Ceci étant, j’ai la dernière version de firefox et le son fonctionne (par
    contre les audio sont mal positionnés).
    Je regarderai la semaine prochaine pour faire la correction pour la prochaine version de wims.
    Sinon, vous pouvez toujours m’envoyer par mail votre solution (juste le code html).

    Bernadette

    PS : il faut aussi que quicktime soit à jour pour certains systèmes.

  • #2255

    Yves Dhenain
    Participant

    Merci,
    je pense avoir compris la réponse. Je vais regarder de plus près ce week end pour voir si c’est réellement un problème de balises, mais visiblement le format mp3 n’est pas géré par Firefox (problème de licence). Il faut du ogg.

    Quicktime n’est pas disponible sous linux

  • #2257

    Chantal Causse
    Admin bbPress

    Chez moi aussi, le son marche avec firefox (17.0.1).
    Les lecteurs audio sont effectivement tout en bas des cases, ce qui n’est pas bien pratique.
    Et un autre défaut, c’est qu’au chargement de la page, tous les audios se lancent en même temps, ce qui fait une belle cacophonie. Par contre ensuite, on peut les lancer un par un et ça marche.

Vous devez être connecté pour répondre à ce sujet.