damir

Toutes mes réponses sur les forums

20 sujets de 1 à 20 (sur un total de 43)
  • Auteur
    Messages
  • en réponse à : transition à une machine 64 bits #6574
    damir
    Modérateur/modératrice
    Up
    0
    Down

    Bonjour Olivier,

    Je reviens sur ce sujet vieux de 2 ans (déjà…). En ce qui concerne le passage 32->64 bits, y a-t-il dans le dossier complet WIMS, à part les fichiers de code compilés, d’autres fichiers qui auraient du mal à passer de 32 en 64 bits (je pense à des fichiers de données binaires d’un format particulier). Je sais que les fichiers texte passent très bien ainsi que les fichiers gzippés.

    On va essayer mais si tu as des souvenirs, ils seront les bienvenus.

    Amicalement (WIMSement ?)
    Damir

    en réponse à : propagation des données sur plusieurs exercices #5807
    damir
    Modérateur/modératrice
    Up
    0
    Down

    Très intéressant, Julien.
    Est-ce que tu peux donner un exemple OEF ? Ou faut il passer par var.proc ?
    Là aussi un squelette d’exemple serait super.
    Si je comprends bien, tout ça ne fonctionne que pour des exercices qui sont dans le même module ?

    Amicalement
    Damir

    en réponse à : propagation des données sur plusieurs exercices #5796
    damir
    Modérateur/modératrice
    Up
    0
    Down

    Bonjour Marie-Joëlle,

    J’ai eu exactement le même problème il y a deux semaines. Je n’ai pas trouvé de solution mais j’ai simplement prévenu les étudiants dans les exercices que les données pouvaient changer… pas idéal.

    amicalement

    Damir

    en réponse à : récupération de données partielles d’un examen #5781
    damir
    Modérateur/modératrice
    Up
    0
    Down

    Ensuite je dois avoir un script perl perso qui récupère les réponses des élèves et les bonnes réponses (si l’exercice n’utilisait pas les conditions,).

    Ça m’intéresse. J’ai vu que ce sont les variables w_replyX et w_replygoodX qui contiennent l’info (?)
    Mais si ton script peut aider, il est le bienvenu.

    Dans tous les cas, c’est à toi de recalculer la note.

    Oui, bien sûr

    PS: on conseille toujours pour les examens de ne pas faire des exercices à trop d’étapes. Mais c’est trop tard !

    C’est ce que j’ai dit à la personne qui faisait l’examen. On a essayé de corriger ça pour le second examen…

    en réponse à : Examen sans réponses #5767
    damir
    Modérateur/modératrice
    Up
    0
    Down

    Voici ce que j’ai essayé pour chaque exercice :

    – dans le paramétrage de l’affichage des aides (mode expert)
    –> Afficher la bonne réponse : jamais
    –> Afficher la solution : jamais
    –> afficher le feedbak : jamais

    Mais ça n’a pas vraiment l’air de fonctionner. J’ai évidemment fait sur les exercices de la feuille avant de créer l’examen. Ça ne fonctionne pas non plus sur la feuille seule.

    La version de WIMS est la 4.19a de fin aout 2019

    en réponse à : Effacement d'un compte étudiant #5259
    damir
    Modérateur/modératrice
    Up
    0
    Down

    Bon, j’ai trouvé comment contourner le problème. Attention, ceci n’est valable que parce que l’utilisateur en question n’avait pas travaillé du tout en tant que participant.
    Le fichier contenant les informations sur le participant est dans le dossier .users dans la classe ou le groupement de classes qui m’intéresse, j’ai donc d’abord éliminé le fichier concernant ce participant. Mais…
    … il faut aussi modifier les fichiers
    .userlist
    .userlist_external
    .usernextlist
    .userprevlist

    Ensuite, lorsqu’on ajoute le participant en tant qu’enseignant via le LDAP, les bons fichiers sont remplis (dans .users et .teacherlist et .teacherlist_external )

    Je ne comprends toujours pas pourquoi « effacer le participant » n’a pas marché.

    Damir

    en réponse à : Effacement d'un compte étudiant #5258
    damir
    Modérateur/modératrice
    Up
    0
    Down

    plus simplement, où sont stockés les noms/identifiants des participants à une classe ? On peut peut-être tout simplement désinscrire la personne ?

    en réponse à : Bouton "Enregistrer" ne fonctionne pas #4592
    damir
    Modérateur/modératrice
    Up
    0
    Down

    Ok, j’avais trouvé le hack, merci Bernadette.
    Je ne suis pas sûr qu’en période de production, on installe une nouvelle version de WIMS.

    Damir

    en réponse à : nécessité de cliquer 20 fois pour revenir à l'accueil #4531
    damir
    Modérateur/modératrice
    Up
    0
    Down

    C’est vraiment plus pratique quand c’est la personne qui rencontre le problème qui le décrit. Déjà que je n’arrive pas à reproduire ce bug, le « téléphone arabe » n’aide pas 😉

    En fait, j’ai eu le problème moi aussi sur Firefox il y a 10 minutes, et c’est exactement tel que je l’ai décrit plus haut.

    Tu n’as pas répondu concernant le thème utilisé.

    C’était le thème standard

    Dans un établissement, s’agit-il plutôt d’un niveau, classe, programme ou cours ?

    Nous sommes en train de créer une structure donc je ne peux pas te donner d’infos plus précises, ça va dans tous les sens en ce moment.

    J’ai en tout cas testé sur Firefox et Chrome dans une classe d’un groupement de classes. J’ai ajouté des feuilles, des examens, des exercices… et à chaque fois j’ai pu revenir à la page d’accueil sans rencontrer de bug.
    Ceci dit, cela m’a permit de remarquer qu’il faut d’abord remonter dans la page d’accueil de la sous-classe avant d’avoir la possibilité de remonter au niveau supérieur. Mais c’est plutôt un souci d’ergonomie qu’un bug. on est loin d’avoir à cliquer 20 fois…

    Quand ça arrive, on est toujours en train d’utiliser le bandeau « breadcrumbs » (je ne connais pas le mot en français).

    J’essaie d’identifier un cas minimal et quand ça arrive, j’essaie de le reproduire.

    Merci !!!

    en réponse à : nécessité de cliquer 20 fois pour revenir à l'accueil #4527
    damir
    Modérateur/modératrice
    Up
    0
    Down

    Salut Olivier,
    C’est Gilles qui m’a décrit le problème. Il arrive quand on est en train de travailler dans une classe qui est dans un établissement ou un groupement de classes. Après quelques opérations du genre création de classe, de cours, de feuille, etc… on veut revenir à l’arborescence initiale, l’accueil du groupement ou de l’établissement et c’est là qu’il faut cliquer un très grand nombre de fois avant de recharger effectivement la page d’accueil.
    Comme je le disais, sur OSX et Chrome. Je n’ai pas vraiment testé sur les autres navigateurs.

    C’est tout ce que je peux dire pour l’instant.

    en réponse à : nécessité de cliquer 20 fois pour revenir à l'accueil #4518
    damir
    Modérateur/modératrice
    Up
    0
    Down

    J’ai oublié de préciser : MacOSX avec Chrome

    en réponse à : Bug à la création de compte étudiant #3947
    damir
    Modérateur/modératrice
    Up
    0
    Down

    Ok, ça semble fonctionner après reboot…

    en réponse à : réponse jmolclick #3549
    damir
    Modérateur/modératrice
    Up
    -1
    Down

    Il y a juste une erreur
    [Error] Failed to load resource: the server responded with a status of 404 (Not Found) (fr.po, line 0)
    mais je ne pense pas que ça soit le problème
    le résultat est le même sur wimstest1

    Damir

    en réponse à : flydraw et latex ne se lance pas #3192
    damir
    Modérateur/modératrice
    Up
    0
    Down

    la librairie gd est bien installée. Par contre, j’ai un message d’erreur :

    ERROR from sh:
    Can't locate WebService/Validator/HTML/W3C.pm in @INC (@INC contains: /opt/local/lib/perl5/site_perl/5.16.3/darwin-thread-multi-2level /opt/local/lib/perl5/site_perl/5.16.3 /opt/local/lib/perl5/vendor_perl/5.16.3/darwin-thread-multi-2level /opt/local/lib/perl5/vendor_perl/5.16.3 /opt/local/lib/perl5/5.16.3/darwin-thread-multi-2level /opt/local/lib/perl5/5.16.3 /opt/local/lib/perl5/site_perl /opt/local/lib/perl5/vendor_perl .).
    BEGIN failed--compilation aborted.

    mais perl5 n’est pas un répertoire mais un exécutable (?)

    j’ai aussi essayé de recompiler flydraw, sans erreur :

    gcc -g -O2 -Wall   -DGNU_SOURCE -DVERSION_DATE=\"2015-11-23\" flylines.o nametab.o vimg.o objects.o flydraw.o -L../../lib -lm -lgd -lwims -o flydraw
    strip flydraw
    ./flydraw table
    Table orders OK.
    cp flydraw ../../other/bin/flydraw
    chmod a+x ../../other/bin/flydraw
    ./htmldoc.sh >../../public_html/scripts/help/en/flydraw.phtml
    for i in fr cn ca ; do ./htmldoc.sh $i >../../public_html/scripts/help/$i/flydraw.phtml ; done
    ./flydraw2js.pl ; cp flydraw.js ../../public_html/scripts/js/edit_area/reg_syntax/flydraw.js ; rm flydraw.js
    

    Bref, je suis un peu dans le brouillard.
    Par contre, faut-il inclure /opt/local/xxx dans une variable C_INCLUDE ou C_PATH ou LIBRARY_PATH pour que wims s’execute ? je ne l’ai fait que pour la compilation. Si oui, dans quel fichier ?

    en réponse à : flydraw et latex ne se lance pas #3182
    damir
    Modérateur/modératrice
    Up
    0
    Down

    pour le souci de tex, en fait je crois que le mieux est encore que tu passe à MAthML :
    il te suffit de choisir « MathML » dans le champ « Default formula position / MathML »

    Le souci est plus profond. J’ai vraiment besoin de flydraw et j’ai peur que d’autres outils ne soient pas disponibles.

    en réponse à : flydraw et latex ne se lance pas #3179
    damir
    Modérateur/modératrice
    Up
    0
    Down

    Salut Olivier,

    Ordinateur-de-Damir-Buskulic:log buskulic$ which tex
    /opt/local/bin/tex
    Ordinateur-de-Damir-Buskulic:log buskulic$ tex
    This is TeX, Version 3.14159265 (TeX Live 2015/MacPorts 2015_7) (preloaded format=tex)
    **
    

    Chemin que je crois avoir inclus dans le chemin standard de wims.

    Sinon, quel est le chemin normal de l’executable flydraw ?

    en réponse à : problème de précision jsxgraphcurve #3014
    damir
    Modérateur/modératrice
    Up
    0
    Down

    Salut Julien,

    Je voudrais pouvoir analyser la réponse moi-même et dire si elle est juste ou fausse. Il ne s’agit pas de la variable \reply1, qui renvoie la réponse de l’étudiant seulement une fois l’analyse faite. Si on veut analyser soi-même la réponse, on met une variable qui n’existe pas (appelons-la \jstest comme dans mon exemple) dans le second champ de \answer puis on applique la commande \condition APRES la \answer (comme dans mon exemple).

    Ceci fonctionne bien avec d’autres types, mais jsxgraphcurve ne permet pas de récupérer les données dans la variable « inconnue » \jstest.

    On a l’impression que ce n’est pas prévu dans le code de jsxgraphcurve. Par contre, ce devrait être possible d’après la doc sur le type javacurve.

    Je ne sais pas si je suis très clair…

    Amicalement

    Damir

    en réponse à : problème de précision jsxgraphcurve #3010
    damir
    Modérateur/modératrice
    Up
    0
    Down

    Quatrième message…
    jsxgraphcurve ne semble pas supporter l’analyse autonome de la réponse avec \condition…

    C’est le cas, ou il faut qu’on s’acharne ? Je joins le code qui ne fonctionne pas. En fait, l’image n’apparaît pas, juste un cadre avec un trait de contour…

    Damir

    \title{ Droite}
    \precision{100}
    \css{<style type= »text/css »>
    .jxgbox {margin-left:auto;margin-right:auto;}
    .jsxgraph_button {text-align:center;}
    </style>}
    
    \text{dessin=draw(800,300
    hline 400,150,black
    vline 400,150,black
    hline 600,75,black
    vline 600,75,black
    text black,400,150,large,O
    text black,600,75,large,A
    )
    }
    \statement{ Tracer la droite passant par 0 et par A.
    \embed{r1,800x300;\dessin;sline,400,150,600,75}
    }
    \answer{}{\jstest;}{type=jsxgraphcurve}
    \condition{analyse qui fonctionne}{1=1}
    en réponse à : problème de précision jsxgraphcurve #3009
    damir
    Modérateur/modératrice
    Up
    0
    Down

    En fait (troisième message, désolé), la note est correcte, c’est un bug dans l’affichage « bonne » ou « mauvaise » réponse. Ce devrait être facile à corriger (je crois).

    Par contre, nous sommes en train d’essayer de récupérer les données de réponse de l’étudiant pour mettre des conditions dessus. Ce serait bien de mettre dans la doc (soit dans javacurve, soit dans jsxgraphcurve) un exemple.

    Merci encore.

    Damir

    en réponse à : problème de précision jsxgraphcurve #3008
    damir
    Modérateur/modératrice
    Up
    0
    Down

    le code :

    \title{ Droite}
    \precision{100}
    \css{<style type= »text/css »>
    .jxgbox {margin-left:auto;margin-right:auto;}
    .jsxgraph_button {text-align:center;}
    </style>}
    
    \text{dessin=draw(800,300
    hline 400,150,black
    vline 400,150,black
    hline 600,75,black
    vline 600,75,black
    text black,400,150,large,O
    text black,600,75,large,A
    )
    }
    \statement{ Tracer la droite passant par 0 et par A.
    \embed{r1,800x300}
    }
    \answer{}{\dessin;sline,400,150,600,75}{type=jsxgraphcurve}{option=precision=5}
20 sujets de 1 à 20 (sur un total de 43)