Installation sous Debian 9.4 / Ubuntu 18.04

Accueil Forums Gestion d’un serveur WIMS Installation d’un serveur WIMS Installation sous Debian 9.4 / Ubuntu 18.04

Ce sujet a 4 réponses, 2 participants et a été mis à jour par Olivier Olivier, il y a 5 mois et 3 semaines.

  • Auteur
    Messages
  • #4407
    Pascal Denis
    Pascal Denis
    Participant

    Bonjour à tous,

    je suis actuellement sous Ubuntu 16.04, mais on me pousse à basculer sous Debian 9.4 ou Ubuntu 18.04. Les essais que j’ai réalisé sur machine virtuelle me donnent les mêmes résultats. Je précise que je suis la doc du wiki et que je procède à l’installation comme pour les autres versions (Debian 7, ubuntu 16.04)

    — versions testée : 4.13e, 4.14a 4.15b
    — Compilation OK
    — Pré-installation OK, par contre lors de la mise en place sous apache2, voici les messages :

    root@Debian:/home/wims# ./bin/setwrapexec
    root@Debian:/home/wims# ./bin/setwimsd
    root@Debian:/home/wims# ./bin/apache-config

    ## This script adds WIMS-related definitions to Apache config. ##

    Detecting which HTTP server to execute…
    => HTTP server detected as apache2
    Searching apache2 conf file…
    # Linux Type: debian
    # Release : stretch
    => HTTPd conf file : ./conf.d/wims.conf
    Searching HTTPd root…
    => HTTPd root found : /etc/apache2
    Config test…
    grep: ./conf.d/wims.conf: No such file or directory
    Searching HTTPd major version…
    => HTTPd major version found : 24
    mv: cannot move ‘/tmp/wims-apache.conf’ to ‘./conf.d/wims.conf’: No such file or directory
    ## WIMS Configuration added to your HTTPd server conf. ##

    Now you must restart your httpd to make the new configuration
    take effect.
    If you don’t know how to do so: just shut down the system then
    restart it.

    root@Debian:/home/wims# a2enmod cgi
    Your MPM seems to be threaded. Selecting cgid instead of cgi.
    Enabling module cgid.
    To activate the new configuration, you need to run:
    systemctl restart apache2
    root@Debian:/home/wims# a2enmod cgid
    Module cgid already enabled
    root@Debian:/home/wims# systemctl restart apache2

    N.B. L’installation via le package debian 4.13c fonctionne …

    si vous avez des idées …

  • #4408
    Pascal Denis
    Pascal Denis
    Participant

    Complément d’information : la version 4.15b passe sans soucis sous debian 8.10 aussi

  • #4409
    Olivier
    Olivier
    Admin bbPress

    Bonjour Pascal,

    J’ai modifié le script d’installation pour Apache, ce qui devrait permettre l’installation sur les prochaines versions de Debian sans souci :

    https://wimsedu.info/websvn/revision.php?repname=wimsdev&path=%2F&isdir=1&rev=12205

    Dès la prochaine version de WIMS, le souci sera automatiquement résolu.
    En attendant, tu peux simplement modifier le fichier « wims/bin/apache-config » et à la ligne 67 il suffit d’ajouter « stretch » à la liste « trusty|jessie|xenial » (ou de remplacer un de ces 3 par « stretch ».

    Olivier Bado - Université Nice Sophia Antipolis

  • #4410
    Pascal Denis
    Pascal Denis
    Participant

    C’est nickel !

    J’ai pu noter aussi sous debian 9.4 la nécessite de remplacer pour gap :

    gap.sh -T -m 64M par gap tout simplement pour être reconnu dans l’interface de gestion

  • #4411
    Olivier
    Olivier
    Admin bbPress

    C’est nickel !

    J’ai pu noter aussi sous debian 9.4 la nécessite de remplacer pour gap :

    gap.sh -T -m 64M par gap tout simplement pour être reconnu dans l’interface de gestion

    Oui en effet, c’est un bug déja expliqué ici :

    https://wiki.wimsedu.info/doku.php?id=installation:debian:bugs

    (normalement il faut juste retirer le « .sh », on peut conserver le « -T -m 64M »)

    Olivier Bado - Université Nice Sophia Antipolis

Vous devez être connecté pour répondre à ce sujet.