pb apache 2.4 debian-live-8.7.1-i386

Accueil Forums Gestion d’un serveur WIMS Installation d’un serveur WIMS pb apache 2.4 debian-live-8.7.1-i386

Vous lisez 3 fils de discussion
  • Auteur
    Messages
    • #3800
      Merci, ca m’a aidé
      Up
      0
      Down
      Pas très utile.
      Jean-Baptiste LagrangeJean-Baptiste Lagrange
      Participant

      Bonjour,
      je poursuis l’installation sur Gigabrix
      système debian-live-8.7.1-i386
      puis apache 2.4, les logiciels nécessaires et wims-4.13d, compilation …

      j’exécute apache-config et je constate qu’il met un wims.conf dans conf-enabled

      quand je fais
      a2enmod cgi
      j’ai le message
      Your MPM seems to be threaded. Selecting cgid instead of cgi

      et quand je cherche à accéder à wims (http://localhost/wims)
      il me propose d’enregistrer le module !

      Après recherche, il semble normal que apache lance cgid plutôt que cgi.
      Est-ce qu’il ya un pb entre wims et cgid ?

      Merci à qui pourra m’aider.

      JB lagrange

    • #3806
      Merci, ca m’a aidé
      Up
      0
      Down
      Pas très utile.
      Jean-Baptiste LagrangeJean-Baptiste Lagrange
      Participant

      petite mise à jour.
      Le tuto d’installation que j’utilise est
      http://wiki.wimsedu.info/doku.php?id=installation:debian

      en le relisant je n’étais pas sûr d’avoir lancé setwimsd.
      En effet dans le readme de l’installation, je comprends qu’il ne faut le faire que pour une usage mono.

      Après avoir lancé setwimsd ça a changé, mais pas en bien !
      j’ai l’erreur
      ======================
      ERROR.

      wims has detected an error in the module ‘???’.

      In file  », line 1: executable.

      HTTP/1.0 420 WIMS Nested Error
      Date: Thu Apr 6 14:56:53 2017
      Connection: close

      WIMS error processing aborted on nested error.

      executable
      ===========================
      Je comprends que apache a lancé le CGI, mais que celui-ci est en erreur !
      Please Help !

    • #3807
      Merci, ca m’a aidé
      Up
      0
      Down
      Pas très utile.
      OlivierOlivier
      Admin bbPress

      Bonjour,
      pour ma part, les serveurs WIMS que je gère sont sur Debian 7.11, et c’est bien cgid qui est activé dans Apache, sans que cela pose de probleme.

      J’ai également installé un Debian 8.7 sur une VM, et WIMS y fonctionne également sans souci.
      Avez-vous suivi la doc d’install disponible sur le wiki ?

      http://wiki.wimsedu.info/doku.php?id=installation:debian

      Olivier Bado-Faustin / Université Nice Sophia Antipolis

    • #3809
      Merci, ca m’a aidé
      Up
      0
      Down
      Pas très utile.
      Jean-Baptiste LagrangeJean-Baptiste Lagrange
      Participant

      Refait une installation en suivant plus attentivement le tutoriel (sauf Povray).

      Compilation OK, sauf trois erreurs
      index wimsdoc …
      bin/mkindex: 234: bin/mkindex: ./Makeindex: Permission denied
      cleanup
      cp: impossible d’évaluer « oef.com/* »: Aucun fichier ou dossier de ce type
      find: « texo.?? »: Aucun fichier ou dossier de ce type
      cp: impossible d’évaluer « texo/* »: Aucun fichier ou dossier de ce type

      Je ne sais pas si c’est grave ! Pour les quelques essais que j’ai fait, c’est OK, sauf administration:
      « restaurer » Erreur . Type d’erreur : noyear
      par « sauvegarde »: les deux fichiers de classe sauvegardés dans la phase antérieure du projet sont refusés: non conforme.

      Reste à voir ce que ça donnera dans les classes africaines !

      Merci à Olivier.

      JB Lagrange LDAR Université Paris-Diderot Projet PReNuM-AC

Vous lisez 3 fils de discussion
  • Vous devez être connecté pour répondre à ce sujet.