Wims et O2switch

Vous lisez 6 fils de discussion
  • Auteur
    Messages
    • #6303
      Pierre Poirier
      Participant
      Up
      0
      Down

      Bonjour à tous
      Nouveau sur le forum, je gère le Moodle de notre établissement scolaire (structure sportive réduite). Nous sommes sur O2switch et je me demandais si quelqu’un avait réussi à installer Wims. Nous voudrions utiliser le nouveau plugin Moodle Wims-Course.

      Merci pour les infos

      Pierre

    • #6305
      Olivier
      Maître des clés
      Up
      0
      Down

      Bonjour,
      Je ne connais pas vraiment O2switch, mais à priori peu importe l’hébergeur que vous choisissez, l’important c’est qu’il vous convienne ^^.
      Pour installer WIMS, je vous invite surtout à suivre la doc ici :
      https://wiki.wimsedu.info/doku.php?id=installation:a

      nb : le plugin Moodle/WIMS n’est pas vraiment nouveau ^^. Mais c’est vrai que ce n’est que depuis la dernière version qu’il est référencé par Moodle.org

      Olivier Bado-Faustin / Université Côte d’Azur

      • #6306
        Pierre Poirier
        Participant
        Up
        0
        Down

        Merci pour la réponse.
        En effet, il s’agit de la dernière mise à jour.
        Je vais essayer mais je n’ai encore jamais fait cela. Je tiendrai au jus.

        Pierre

      • #6307
        Pierre Poirier
        Participant
        Up
        0
        Down

        Bonjour
        J’ai essayé mais apt-get bloque.
        Réponse du technicien d’O2switch
        « Sur l’hébergement, vous n’avez pas d’accès root mais uniquement des accès client linux classique.
        Il faudrait alors voir si vous pouvez faire l’installation en commande linux non root. »
        Mais visiblement, même en Mode « chroot », il faut apt.

        Est-ce qu’il existe une autre manière d’installer que via apt-get, par exemple en récupérant une arborescence de fichiers à copier sur le serveur… Mais dans ce cas il risque de manquer des paquets que je ne pourrais pas installer (sans le droit d’utiliser apt-get).
        Bref, un peu perdu

        Pierre

    • #6309
      Olivier
      Maître des clés
      Up
      0
      Down

      Bonjour,
      En effet, je n’avais pas vu qu’O2switch ne propose que des hébergement Web, pas d’hébergement de serveur.
      Sans votre propre serveur, vous ne pourrez pas installer WIMS en effet.
      Vous devriez vous tourner vers d’autres hébergeurs, qui proposent des « serveurs cloud », par exemple :

      Olivier Bado-Faustin / Université Côte d’Azur

    • #6313
      Valentin Philip
      Participant
      Up
      0
      Down

      Je prend le relais de Pierre car nous sommes deux dans l’aventure plugin wims course sur notre serveur moodle.
      Depuis le premier message de ce topic, nous avons suivi vos conseils et installé un serveur wims autonome (hébergé chez LWS). Cela nous permet d’avoir un accès root au serveur afin de pouvoir intégrer les deux fichiers json indiqué dans la doc du plugin wims sur moodle. Nous avons suivi cette doc et celle du wiki de wimsedu.
      Cependant le serveur moodle nous renvoie toujours un message d’erreur.
      Il semblerait que les trois variables back_url back_ident et back_password qui apparaissent dans le calling back des deux fichiers json ne soit pas bien renseignés.
      Pouvez vous nous indiquer qu’est ce qu’il faudrait mettre dans ces variables?
      Bien cordialement

      • Cette réponse a été modifiée le il y a 5 mois et 2 semaines par Valentin Philip.
      • Cette réponse a été modifiée le il y a 5 mois et 2 semaines par Valentin Philip.
      • #6319
        Olivier
        Maître des clés
        Up
        0
        Down

        Les variables « back_url, back_ident, et back_password » ne sont pas utilisés, votre souci ne vient donc pas de là. Il faudrait connaitre exactement votre message d’erreur.

        Olivier Bado-Faustin / Université Côte d’Azur

    • #6316
      Valentin Philip
      Participant
      Up
      0
      Down

      Je précise que les deux fichiers json sont bien intégrés dans le serveur wims au bout du chemin home/wims/log/classes/.connections comme indiqué dans la doc

      De plus à la lecture du message d’erreur, il semblerait qu’il y ait un problème avec le fichier wimscommswrapper.class.php intégrer dans le serveur moodle par l’intermédiaire du plugin wimscourse
      Bref, tous ceux ci dépasse complètement nos maigres compétences en informatique et nous avons vraiment besoin d’aide pour finaliser cette installation précieuse pour notre enseignement

      Merci de nous aider pour finaliser

    • #6317
      Valentin Philip
      Participant
      Up
      0
      Down

      Ci dessous le message d’erreur que nous renvoie le serveur moodle une fois que l’on clique sur l’activité wims crée dans moodle à l’aide du plugin wims course qui à l’air d’être installé :

      WIMS Execute: http://wims-sshn.com/wims/wims.cgi?module=adm/raw&job=checkclass&code=244&ident=moodlejson&passwd=Albertville_1992&qclass=109764&rclass=moodle_9764
      WIMS comms success
      ERROR: /home/pzty2702/sascne.moodlesshn.com/mod/wims/wimscommswrapper.class.php:316: WIMS JSON OK response not matched: (for code 244):
      message: Identification Failure : bad login/pwd
      WIMS Execute: http://wims-sshn.com/wims/wims.cgi?module=adm/raw&job=addclass&code=928&ident=moodlejson&passwd=Albertville_1992&qclass=109764&rclass=moodle_9764&data1=description%3Dtroisinstitution%3DMoodle+SSHN%2FWIMS
      %0Asupervisor%3DValentin+Philip%0Aemail%3Dvalentin.philip%40gmail.com%0Apassword%3DPwd449532%0Alang%3Dfr%0Asecure%3Dall%0A&data2=lastname%3DPhilip%0Afirstname%3DValentin%0Apassword%3DPwd239943%0A
      WIMS comms success
      ERROR: /home/pzty2702/sascne.moodlesshn.com/mod/wims/wimscommswrapper.class.php:316: WIMS JSON OK response not matched: (for code 928):
      message: Identification Failure : bad login/pwd
      job:addclass – SENDED PARAMS: qclass=109764&rclass=moodle_9764&data1=description=trois institution=Moodle SSHN/WIMS supervisor=Valentin Philip email=valentin.philip@gmail.com password=Pwd449532 lang=fr secure=all &data2=lastname=Philip firstname=Valentin password=Pwd239943
      object(stdClass)#243 (3) { [« status »]=> string(5) « ERROR » [« code »]=> string(3) « 928 » [« message »]=> string(38) « Identification Failure : bad login/pwd » }
      Impossible d’accéder à la classe WIMS.

      → Identification Failure : bad login/pwd
      → Le serveur est probablement indisponible. Merci de retester dans quelques minutes, ou informez-en l’administrateur.

    • #6320
      Olivier
      Maître des clés
      Up
      0
      Down

      Le message important ici est :
      → Identification Failure : bad login/pwd

      ==> le mot de passe que vous avez renseigné dans les fichiers json ne correspond pas à celui que vous avez défini dans le plugin wims.

      Olivier Bado-Faustin / Université Côte d’Azur

      • #6325
        Pierre Poirier
        Participant
        Up
        1
        Down

        Bonjour
        Solution trouvée en enlevant l’underscore du mdp…
        Tout fonctionne.
        Merci pour l’aide et à bientôt

Vous lisez 6 fils de discussion
  • Vous devez être connecté pour répondre à ce sujet.