Problème d'affichage d'image

Accueil Forums Programmation WIMS Programmation d’exercices OEF Problème d'affichage d'image

Ce sujet a 4 réponses, 3 participants et a été mis à jour par  bernadette, il y a 6 mois.

  • Auteur
    Messages
  • #3681

    Bonjour,
    J’ai réussi assez facilement à créer un QCM avec createQCM dans Createxo avec une liste de boutons à cocher mais je voudrais insérer une image (des molécules enregistrées au format png) dans ce QCM. J’ai essayé avec Modtool en suivant la procédure de la fiche 62 de « découvrir et utiliser WIMS ».
    J’ai eu beau insérer la ligne de code <img src="imagedir/MON_IMAGE.jpg" /> un peu partout dans le source mais l’image n’apparaissait pas sur le test. J’ai juste réussi à faire s’afficher l’image en cliquant sur le bouton aide en écrivant le code \help{ <img src="imagedir/pbconcoursED5.png" /> }.
    Comment la faire apparaitre et la placer à l’endroit voulu sur le QCM?
    Merci d’avance pour votre aide.

    • Ce sujet a été modifié le il y a 6 mois et 1 semaine par  Olivier.
    • Ce sujet a été modifié le il y a 6 mois et 1 semaine par  Olivier. Raison: style "code" sur les instructions pour les afficher

    Jean-François Berrien

  • #3691

    Olivier
    Admin bbPress

    Bonjour,
    Lorsque je dépose une image dans createxo, ce dernier me fournit le code à utiliser, en l’occurence :

    <img src="\imagedir/calimero.png"/>

    Je pense donc qu’il manque un « anti slash » devant votre « imagedir » dans le code que vous indiquez.

    Olivier Bado - Université Nice Sophia Antipolis

  • #3692

    Bonsoir, merci pour votre réponse mais cela ne fonctionne toujours pas.

    Jean-François Berrien

  • #3696

    bernadette
    Admin bbPress

    Vous avez bien vérifié que l’image est « dans l’exercice » (dans la liste quand on
    fait ajouter une image)? Je suppose que oui, mais bon !

    Pouvez-vous m’envoyer l’image et le source de l’exercice. Il est difficile
    de déboguer comme cela.

    Bernadette

  • #3698

    bernadette
    Admin bbPress

    En fait, le problème était qu’il faut éviter de mettre à la fois ? et :
    dans le texte d’explication d’un modèle préparé Vrai/Faux !
    Une solution est de mettre le texte dans asis(…)
    mais cela m’ennuie de le faire systématiquement car cela peut poser d’autres problèmes (cas des formules mathématiques par exemple).Je ne sais plus …
    A réfléchir.

    Bernadette

Vous devez être connecté pour répondre à ce sujet.