Image qui disparait dans imageclick

Accueil Forums Programmation WIMS Programmation d’exercices OEF Image qui disparait dans imageclick

Mots-clés : 

Vous lisez 6 fils de discussion
  • Auteur
    Messages
    • #2384
      Yves NOEL
      Participant
      Up
      0
      Down

      J’ai constaté un problème lors de l’utilisation d’Imageclick dans une classe (reproductible sur plusieurs serveurs WIMS (4-07c)) :
      Lorsqu’on choisit l’option « zone »
      l’image disparait et on se retrouve à définir la zone à l’aveugle (On a plus que la ligne polygonale sur fond blanc).

      Par contre sur ces mêmes serveurs cela fonctionne en passant uniquement par un compte modtool (en dehors de toute classe).

      Une idée?

      Yves

    • #2385
      eric
      Participant
      Up
      0
      Down

      Le problème ne semble pas (uniquement) lié à 4.07c car ça fonctionne sur le serveur de Caen (en 4.07c) et sur une machine sous svn. Mais je ne vois pas d’explication pour l’instant.
      Eric

      • #2386
        Yves NOEL
        Participant
        Up
        0
        Down

        J ai essayé sur :
        -auto (psud)
        – wimstest1
        – UPMC
        – mon serveur perso

        A chaque fois la même chose.

        Tu as bien essayé l option « zone » puis ligne polygonale par exemple.
        C est au moment ou on clique pour désigner l intérieur de la zone que l image disparaît.

    • #2387
      bernadette
      Maître des clés
      Up
      0
      Down

      Oui, j’ai essayé avec zone etc. Mais tu as raison cela ne fonctionne pas sur wimstest1. Je pense que c’est un problème avec la copie d’image dans flydraw.
      Mais je ne peux pas déboguer avant lundi (puisque cela fonctionne sur mon serveur perso).

      Il faudrait voir ce que vaut la variable $insdraw_filebase dans ce cas (contient la liste des répertoires où trouver l’image à copier), voir si on peut directement copier l’image dans flydraw (un truc du type
      copy 0,0,-1,-1,-1,-1,nom_image)
      si elle est chargée dans un exercice … Juste des pistes.

      Bernadette

    • #2390
      Julien
      Modérateur
      Up
      0
      Down

      Bonjour,
      Est-ce que le module fonctionnait dans une classe lorsqu’il utilisait java ?
      Merci pour votre réponse.

    • #2391
      Yves NOEL
      Participant
      Up
      0
      Down

      Bonjour Julien,
      Imageclick utilisait java auparavant ?
      Je ne suis pas certain de bien comprendre ta question.
      Peux tu préciser?

      Yves

    • #2392
      Julien
      Modérateur
      Up
      0
      Down

      Hello Yves,

      Je voudrais juste savoir si le module Imageclick fonctionnait en passant par une classe lorsque java était utilisé.
      Si oui cela incrimine le fichier que j’ai transmis à Bernadette wims/public_html/modules/adm/tool/coordclick/zone.phtml pour virer java.
      Il suffit de repartir de l’existant et d’aménager la variable $imgsrc selon que la connexion est passée à travers modtool ou une classe.
      Par contre je n’ai pas trop le temps de regarder pour l’instant car mon ordi est down.

      @+

      • Cette réponse a été modifiée le il y a 6 années et 2 mois par Julien.
    • #2401
      bernadette
      Maître des clés
      Up
      0
      Down

      C’est un problème avec l’utilisation de !insdraw dans un fichier var.proc dans le cas de la copie d’une image extérieure.
      Je pense avoir corrigé. J’espère ne pas avoir abimé le cas de modtool !
      Merci de tester.
      Bernadette

Vous lisez 6 fils de discussion
  • Vous devez être connecté pour répondre à ce sujet.