Wims & Mac OS X Ventura – ça passe avec un peu de bidouille

Accueil Forums Gestion d’un serveur WIMS Installation d’un serveur WIMS Wims & Mac OS X Ventura – ça passe avec un peu de bidouille

Vous lisez 4 fils de discussion
  • Auteur
    Messages
    • #7387
      Avatar photoPascal Denis
      Participant
      Up
      0
      Down
      ::

      Bonjour à tous,

       

      la mise à jour du système Mac nous apporte son lot de surprise à chaque fois 🙂 à ce jour,

      — Xcode 14.1 nécessaire pour faire tourner Homebrew n’existe qu’en version RC2.

      — Homerbrew s’installe correctement, Octave, gap, etc … sont installés / compilés. Pour gap mettre du coup (gap -T -m 64M)

      — Wims se compile sans soucis

      — le pb est que le serveur ne se lance pas avec la version d’apache

      — Cependant …

      1. en installant apache via Homebrew, j’ai suivi https://getgrav.org/blog/macos-monterey-apache-multiple-php-versions)
      2. Ajout de l’écoute du port 80 (Listen 80)
      3. Copier Coller des lignes ajoutées par Wim depuis /private/etc/apache2/http.conf dans /usr/local/etc/httpd/httpd.conf
      4. modification comme dans le wiki pour mod_cgid.so / mod_cgi.so
      5. ça fonctionne !

       

      J’espère que cela permettra à nos chers développeurs de comprendre ou est le pb :–)

       

      puis en ajoutant les lignes de  wims dans la configuration d’apache. Cela fonctionne

      • Ce sujet a été modifié le il y a 1 mois et 1 semaine par Avatar photoPascal Denis.
      • Ce sujet a été modifié le il y a 1 mois et 1 semaine par Avatar photoPascal Denis.
    • #7390
      Avatar photoOlivier
      Maître des clés
      Up
      0
      Down
      ::

      Merci pour ce retour !
      Si j’ai un conseil à donner, c’est de ne jamais installer une grosse maj système lors de sa sortie 🙂
      Pour ma part, j’attend toujours que sorte une vX.1 stable (et que tous les logiciels dont j’ai besoin ont eu le temps de sortir des maj)

      • Cette réponse a été modifiée le il y a 1 mois et 1 semaine par Avatar photoOlivier.

      Olivier Bado-Faustin / Université Côte d’Azur

    • #7397
      Avatar photoPascal Denis
      Participant
      Up
      0
      Down
      ::

      Mise à jour au 05/11

      — Installation de ventura
      — Installation de Xcode 14.1 – disponible depuis le 2/11/22
      — Update de Homebrew
      — brew reinstall gap

      sous l’utilisateur WIMS :

      sudo bin/apache-config
      sudo vi /etc/apache2/httpd.conf pour modifier la ligne
      #LoadModule cgi_module libexec/apache2/mod_cgi.so
      en
      LoadModule cgi_module libexec/apache2/mod_cgi.so
      sudo apachectl restart

      It’s good !

      N.B. pour le message précédent, le serveur apache de ma machine de test était cassé … mea culpa

      • Cette réponse a été modifiée le il y a 3 semaines et 6 jours par Avatar photoPascal Denis.
      • Cette réponse a été modifiée le il y a 3 semaines et 6 jours par Avatar photoPascal Denis.
      • Cette réponse a été modifiée le il y a 3 semaines et 6 jours par Avatar photoPascal Denis.
    • #7455
      Avatar photoOlivier
      Maître des clés
      Up
      0
      Down
      ::

      Je confirme le message de Pascal : je viens d’installer MacOs Ventura 13.0.1, ainsi que Xcode 14.1, et après avoir relancé sudo apachectl start, j’ai bien wims accessible sous http://localhost/wims/, la compilation passe bien également.

      Olivier Bado-Faustin / Université Côte d’Azur

    • #7486
      Avatar photoOlivier
      Maître des clés
      Up
      0
      Down
      ::

      A noter que comme à chaque changement d’OS, il faut aussi lancer un xcode-select --install pour que la compilation se passe bien.

      Olivier Bado-Faustin / Université Côte d’Azur

Vous lisez 4 fils de discussion
  • Vous devez être connecté pour répondre à ce sujet.